All systems operational

Interruptions on mobile network in Belgium

Resolved
Operational
Started 3 months ago Lasted about 5 hours

Affected

Mobile Telephony
Calls
Data
Updates
  • Resolved
    Resolved

    Flexy SIM services are restored.

  • Monitoring
    Monitoring

    Flexy SIM services are restored.

    The issue remains under close monitoring and investigation.

  • Investigating
    Investigating

    We are currently facing a critical incident on our mobile network impacting Flexy SIM card services (calling, sms, data). We are actively working with BASE/Telenet to resolve the issue. Fixed phone and VoIP calls remain unaffected.

    Thank you for your patience and understanding during this time. If you have any questions or concerns, please do not hesitate to reach out to our customer support team.