All systems operational

Service Interruption Notice - Ongoing Incident Affecting Call Operations

Resolved
Major outage
Started about 1 month ago Lasted about 2 hours

Affected

Telephony
Outbound calls
Inbound calls
Mobile Telephony
Calls
Data
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We are pleased to announce that a temporary solution has been successfully implemented to mitigate the recent service disruption, which resulted from complications with an external partner. As a result, calling operations have been reactivated and should now be operating normally for all users.

    It's important to note, however, that the Busy Lamp Field (BLF) functionality was temporarily disabled to avoid an overload of subscriptions. This will be restored shortly

  • Investigating
    Investigating

    We are currently addressing an incident that has impacted our server operations, leading to interruptions in call functionality across our network. Our team is actively investigating the root cause to swiftly restore service to its full capacity.

    Please note, our support line is temporarily unavailable due to this incident. We are committed to resolving this issue promptly and will provide updates as soon as more information becomes available.

    We understand the importance of uninterrupted service and are working diligently to minimize the impact on our users. Thank you for your patience and understanding during this time.